← All CVEs

CVE-2024-45409

CRITICAL 10 PoC CATALOGUED DETECTION TEMPLATE ALL-YEARS

Published 2024-09-10 · Last modified 2024-11-11 · GitHub_M · NVD: Modified

The Ruby SAML library is for implementing the client side of a SAML authorization. Ruby-SAML in <= 12.2 and 1.13.0 <= 1.16.0 does not properly verify the signature of the SAML Response. An unauthenticated attacker with access to any signed saml document (by the IdP) can thus forge a SAML Response/Assertion with arbitrary contents. This would allow the attacker to log in as arbitrary user within the vulnerable system. This vulnerability is fixed in 1.17.0 and 1.12.3.

REPORTED EXPLOITATION

VulnCheck KEV reports exploitation for this CVE. These are source-specific reports; review the details and vendor guidance below.

Exploitation likelihood

10.7%chance of exploitation in 30 days · 96th percentile

○ In CISA KEV● Catalogued PoC◆ SSVC: exploitation poc, automatable yes

Impact if exploited

10CVSS 3.1 · CRITICAL · CNA

  • ConfidentialityHigh
  • IntegrityHigh
  • AvailabilityNone

What an attacker needs

  • ✓Access: Reachable over the network — no local access needed
  • ✓Privileges: No account or privileges required
  • ✓User interaction: No user interaction needed
  • ✓Complexity: No special conditions — reliably repeatable

✓ lowers the bar for an attacker · ⚠ raises it

Proof of concept

Public PoC or exploit resources are catalogued below.

Listed by the named source; Vulnpedia has not tested these resources.

PoC data: JSON

Detection templates

Detection checks are listed separately from PoCs.

Resource commands

nuclei -id CVE-2024-45409 -u https://TARGETDetection template — review its checks and affected versions before use.
curl -s https://vulnpedia.com/cve/CVE-2024-45409/poc.jsonMachine-readable PoC index for this CVE (for automation).

Search for new PoCs

Search GitHub now — results may be empty or unverified.

Tracked sources are checked weekly for the full archive, including PoCs published after the original disclosure. A later release appears after a tracked source lists it and a refresh succeeds.

Data snapshot:

Affected

Vendors Saml Toolkits Onelogin Omniauth Gitlab

Products Ruby Saml Omniauth Saml Omniauth Saml Gitlab

Weakness (CWE)

  • CWE-347: : Improper Verification of Cryptographic Signature

CVSS vector

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N

References and research data (JSON)

Packages and version ranges

Each advisory describes its own package and affected ranges. A boundary applies to that range; it is not a universal upgrade recommendation.

  • ruby-saml RubyGems

    pkg:gem/ruby-saml

    ECOSYSTEM range
    • All earlier versions (introduced 0)
    • Fixed boundary (excluded): 1.12.3
    80 explicitly listed affected versions

    0.0.5, 0.0.6, 0.0.7, 0.0.8, 0.2.1, 0.2.2, 0.2.3, 0.3.0, 0.3.1, 0.3.2, 0.3.3, 0.3.4, 0.4.0, 0.4.1, 0.4.2, 0.4.3, 0.4.4, 0.4.5, 0.4.6, 0.4.7, 0.5.0, 0.5.1, 0.5.2, 0.5.3, 0.6.0, 0.7.0, 0.7.1, 0.7.2, 0.7.3, 0.8.0, 0.8.1, 0.8.10, 0.8.11, 0.8.12, 0.8.13, 0.8.14, 0.8.15, 0.8.16, 0.8.17, 0.8.18, 0.8.2, 0.8.3, 0.8.4, 0.8.5, 0.8.6, 0.8.7, 0.8.8, 0.8.9, 0.9, 0.9.1, 0.9.2, 0.9.3, 0.9.4, 1.0.0, 1.1.0, 1.1.1, 1.1.2, 1.10.0, 1.10.1, 1.10.2, 1.11.0, 1.12.0, 1.12.1, 1.12.2, 1.2.0, 1.3.0, 1.3.1, 1.4.0, 1.4.1, 1.4.2, 1.4.3, 1.5.0, 1.6.0, 1.6.1, 1.6.2, 1.7.0, 1.7.1, 1.7.2, 1.8.0, 1.9.0

    Additional upstream package constraints
    {
      "database": {
        "source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2024/09/GHSA-jw9c-mfg7-9rx2/GHSA-jw9c-mfg7-9rx2.json"
      }
    }
    GitHub Advisory Database · GHSA-jw9c-mfg7-9rx2 · Updated 2026-08-07T08:11:51.793800677Z
  • ruby-saml RubyGems

    pkg:gem/ruby-saml

    ECOSYSTEM range
    • Introduced version (included): 1.13.0
    • Fixed boundary (excluded): 1.17.0
    4 explicitly listed affected versions

    1.13.0, 1.14.0, 1.15.0, 1.16.0

    Additional upstream package constraints
    {
      "database": {
        "source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2024/09/GHSA-jw9c-mfg7-9rx2/GHSA-jw9c-mfg7-9rx2.json"
      }
    }
    GitHub Advisory Database · GHSA-jw9c-mfg7-9rx2 · Updated 2026-08-07T08:11:51.793800677Z

Unverified PoC candidates

Catalogue matches for further research. These repositories have not been validated as working exploits.

2 candidates

Additional exploitation reports

Source-specific reports, separate from CISA KEV. Repeated observations from one source are not independent confirmations.

Known Affected Software Configurations

VendorProductVersion range
OneloginRuby Saml< 1.12.3
OneloginRuby Saml≥ 1.13.0 and < 1.17.0
OmniauthOmniauth Saml≤ 1.10.3
OmniauthOmniauth Saml2.0.0
OmniauthOmniauth Saml2.1.0
GitlabGitlab< 16.11.10
GitlabGitlab≥ 17.0.0 and < 17.0.8
GitlabGitlab≥ 17.1.0 and < 17.1.8
GitlabGitlab≥ 17.2.0 and < 17.2.7
GitlabGitlab≥ 17.3.0 and < 17.3.3

All CVSS metrics

  • CRITICAL 10 v3.1 · CNA Primary
    CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N
  • CRITICAL 10 v3.1 · NVD Secondary
    CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N
  • CRITICAL 9.8 v3.1 · NVD Primary
    CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

References

Patches & mitigations

Advisories

Technical & other

Sources: NVD · CVE.org · All sources and attribution · EPSS