← Search CVEs

CVE-2026-106119

MEDIUM 6

Published 2026-10-06 · Last modified 2026-10-06

LangChain is a framework for building LLM-powered applications. Prior to 1.3.1, MongoDBChatMessageHistory does not enforce the documented string type for an untrusted structured session identifier at runtime, allowing the identifier to be interpreted as a MongoDB query condition rather than as a literal value when multiple users' histories are stored in a shared MongoDB collection. An attacker able to invoke chat-history operations can read, modify, or delete another user's stored conversation. Applications using authenticated, server-controlled string identifiers are not affected. This issue is fixed in version 1.3.1.

NO EXPLOITATION SIGNALS

No known exploitation, public exploit, or elevated probability at this time. Track for changes.

Exploitation likelihood

0.5%chance of exploitation in 30 days · 40th percentile

○ In CISA KEV ○ Catalogued PoC

Impact if exploited

6CVSS 4.0 · MEDIUM

  • ConfidentialityHigh
  • IntegrityLow
  • AvailabilityNone

What an attacker needs

  • ✓Access: Reachable over the network — no local access needed
  • ⚠Privileges: Requires a low-privilege account
  • ✓User interaction: No user interaction needed
  • ✓Complexity: No special conditions — reliably repeatable
  • ⚠Requirements: Specific conditions must be present

✓ lowers the bar for an attacker · ⚠ raises it

Proof of concept

No public PoC is currently catalogued.

Search for new PoCs

Search GitHub now — results may be empty or unverified.

Tracked sources are checked daily for recent CVEs, including PoCs published after the original disclosure. A later release appears after a tracked source lists it and a refresh succeeds.

Data snapshot:

Affected

Vendors Langchain Ai @Langchain

Products Langchainjs Mongodb

Weakness (CWE)

  • CWE-943: : Improper Neutralization of Special Elements in Data Query Logic

CVSS vector

CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N

References and research data (JSON)

Packages and version ranges

Each advisory describes its own package and affected ranges. A boundary applies to that range; it is not a universal upgrade recommendation.

  • @langchain/mongodb npm

    pkg:npm/%40langchain/mongodb

    SEMVER range
    • All earlier versions (introduced 0)
    • Fixed boundary (excluded): 1.3.1
    Additional upstream package constraints
    {
      "database": {
        "last_known_affected_version_range": "<= 1.3.0",
        "source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-m6rx-h84q-8r95/GHSA-m6rx-h84q-8r95.json"
      }
    }
    GitHub Advisory Database · GHSA-m6rx-h84q-8r95 · Updated 2026-10-08T18:00:08.902627724Z

All CVSS metrics

  • MEDIUM 6 v4.0 · CNA Primary
    CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N
  • MEDIUM 6 v4.0 · NVD Secondary
    CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X

References

Advisories

Technical & other

Sources: NVD · CVE.org · EPSS