← Search CVEs

CVE-2026-106501

CRITICAL 9.6

Published 2026-10-06 · Last modified 2026-10-07

Backstage is an open framework for building developer portals. Prior to 3.3.1, 3.4.1, 4.0.3 and 4.1.0, the @backstage/plugin-scaffolder-backend package is affected by sensitive information exposure in scaffolder. An authenticated Backstage user who can read another user's Scaffolder task may receive internal execution data. In deployments where that data contains credentials for an external service, this may permit disclosure and unauthorized changes in that external service. This issue is fixed in versions 3.3.1, 3.4.1, 4.0.3 and 4.1.0.

ELEVATED IMPACT

Severe if exploited (CVSS 9.6), but no known exploitation and low modeled probability. Patch on a normal cadence.

Exploitation likelihood

0.5%chance of exploitation in 30 days · 41st percentile

○ In CISA KEV ○ Catalogued PoC

Impact if exploited

9.6CVSS 3.1 · CRITICAL

  • ConfidentialityHigh
  • IntegrityHigh
  • AvailabilityNone

What an attacker needs

  • ✓Access: Reachable over the network — no local access needed
  • ⚠Privileges: Requires a low-privilege account
  • ✓User interaction: No user interaction needed
  • ✓Complexity: No special conditions — reliably repeatable

✓ lowers the bar for an attacker · ⚠ raises it

Proof of concept

No public PoC is currently catalogued.

Search for new PoCs

Search GitHub now — results may be empty or unverified.

Tracked sources are checked daily for recent CVEs, including PoCs published after the original disclosure. A later release appears after a tracked source lists it and a refresh succeeds.

Data snapshot:

Affected

Vendors Backstage @Backstage Linuxfoundation

Products Backstage Plugin Scaffolder Backend Backstage\/Plugin Scaffolder Backend

Weakness (CWE)

  • CWE-200: : Exposure of Sensitive Information to an Unauthorized Actor
  • CWE-201: : Insertion of Sensitive Information Into Sent Data

CVSS vector

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N

References and research data (JSON)

Packages and version ranges

Each advisory describes its own package and affected ranges. A boundary applies to that range; it is not a universal upgrade recommendation.

  • @backstage/plugin-scaffolder-backend npm

    pkg:npm/%40backstage/plugin-scaffolder-backend

    SEMVER range
    • All earlier versions (introduced 0)
    • Fixed boundary (excluded): 3.3.1
    Additional upstream package constraints
    {
      "database": {
        "source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-g2v8-7jhw-pp8p/GHSA-g2v8-7jhw-pp8p.json"
      }
    }
    GitHub Advisory Database · GHSA-g2v8-7jhw-pp8p · Updated 2026-10-07T18:15:10.728715918Z
  • @backstage/plugin-scaffolder-backend npm

    pkg:npm/%40backstage/plugin-scaffolder-backend

    SEMVER range
    • Introduced version (included): 3.4.0
    • Fixed boundary (excluded): 3.4.1
    Additional upstream package constraints
    {
      "database": {
        "source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-g2v8-7jhw-pp8p/GHSA-g2v8-7jhw-pp8p.json"
      }
    }
    GitHub Advisory Database · GHSA-g2v8-7jhw-pp8p · Updated 2026-10-07T18:15:10.728715918Z
  • @backstage/plugin-scaffolder-backend npm

    pkg:npm/%40backstage/plugin-scaffolder-backend

    SEMVER range
    • Introduced version (included): 4.0.0
    • Fixed boundary (excluded): 4.0.3
    Additional upstream package constraints
    {
      "database": {
        "source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-g2v8-7jhw-pp8p/GHSA-g2v8-7jhw-pp8p.json"
      }
    }
    GitHub Advisory Database · GHSA-g2v8-7jhw-pp8p · Updated 2026-10-07T18:15:10.728715918Z
  • @backstage/plugin-scaffolder-backend npm

    pkg:npm/%40backstage/plugin-scaffolder-backend

    SEMVER range
    • Introduced version (included): 4.0.4
    • Fixed boundary (excluded): 4.1.0
    Additional upstream package constraints
    {
      "database": {
        "source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-g2v8-7jhw-pp8p/GHSA-g2v8-7jhw-pp8p.json"
      }
    }
    GitHub Advisory Database · GHSA-g2v8-7jhw-pp8p · Updated 2026-10-07T18:15:10.728715918Z

Vendor product assessments

  • registry.redhat.io/ansible-automation-platform/automation-portal@sha256:17e885eb8a7c85fb67221a494bb3b5aba3d78c98029c90a1789d8b496240f9b7_amd64 as a component of Red Hat Ansible Automation Platform 2.2 · fixed

    Vendor assessment for this product only.

    pkg:oci/automation-portal@sha256%3A17e885eb8a7c85fb67221a494bb3b5aba3d78c98029c90a1789d8b496240f9b7?arch=amd64&repository_url=registry.redhat.io/ansible-automation-platform/automation-portal&tag=1792523640

    • vendor fix: For more about Ansible plugins for Red Hat Developer Hub, see References links Vendor guidance
    • workaround: Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.
    Red Hat · CVE-2026-106501 · Updated 2026-10-21T08:50:29+00:00
  • rhdh/red-hat-developer-hub-backstage-plugin-orchestrator-backend as a component of Red Hat Developer Hub · known affected

    Vendor assessment for this product only.

    pkg:oci/red-hat-developer-hub-backstage-plugin-orchestrator-backend?repository_url=registry.redhat.io/rhdh/red-hat-developer-hub-backstage-plugin-orchestrator-backend

    • workaround: Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.
    • none available: Affected
    Red Hat · CVE-2026-106501 · Updated 2026-10-21T08:50:29+00:00
  • rhdh/rhdh-hub-rhel9 as a component of Red Hat Developer Hub · known affected

    Vendor assessment for this product only.

    pkg:oci/rhdh-hub-rhel9?repository_url=registry.redhat.io/rhdh/rhdh-hub-rhel9

    • workaround: Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.
    • none available: Affected
    Red Hat · CVE-2026-106501 · Updated 2026-10-21T08:50:29+00:00
  • ansible-automation-platform/bootc-automation-portal-rhel9 as a component of Self-service automation portal 2 · known affected

    Vendor assessment for this product only.

    pkg:oci/bootc-automation-portal-rhel9?repository_url=registry.redhat.io/ansible-automation-platform/bootc-automation-portal-rhel9

    • workaround: Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.
    • none available: Affected
    Red Hat · CVE-2026-106501 · Updated 2026-10-21T08:50:29+00:00

Known Affected Software Configurations

VendorProductVersion range
LinuxfoundationBackstage\/Plugin Scaffolder Backend< 3.3.1
LinuxfoundationBackstage\/Plugin Scaffolder Backend≥ 3.4.0 and < 3.4.1
LinuxfoundationBackstage\/Plugin Scaffolder Backend≥ 4.0.0 and < 4.0.3
LinuxfoundationBackstage\/Plugin Scaffolder Backend≥ 4.0.4 and < 4.1.0
LinuxfoundationBackstage< 1.49.6
LinuxfoundationBackstage≥ 1.50.0 and < 1.50.5
LinuxfoundationBackstage≥ 1.51.0 and < 1.54.6

All CVSS metrics

  • CRITICAL 9.6 v3.1 · CNA Primary
    CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N
  • CRITICAL 9.6 v3.1 · NVD Secondary
    CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:N

References

Patches & mitigations

Advisories

Technical & other

Sources: NVD · CVE.org · EPSS