← Search CVEs

CVE-2026-106559

MEDIUM 6.3

Published 2026-10-07 · Last modified 2026-10-07

Backstage is an open framework for building developer portals. Prior to 0.3.25, the @backstage/plugin-scaffolder-backend-module-confluence-to-markdown package is affected by improper input validation in confluence to markdown scaffolder module. Insufficient input validation in the Confluence to Markdown scaffolder module could allow an attacker to influence file write operations during template execution. Exploitation requires a Backstage user to run a template that processes attacker-influenced Confluence content. This issue is fixed in version 0.3.25.

NO EXPLOITATION SIGNALS

No known exploitation, public exploit, or elevated probability at this time. Track for changes.

Exploitation likelihood

0.3%chance of exploitation in 30 days · 26th percentile

○ In CISA KEV ○ Catalogued PoC

Impact if exploited

6.3CVSS 3.1 · MEDIUM

  • ConfidentialityNone
  • IntegrityHigh
  • AvailabilityLow

What an attacker needs

  • ✓Access: Reachable over the network — no local access needed
  • ⚠Privileges: Requires a low-privilege account
  • ⚠User interaction: A user must take an action (click / open a file)
  • ✓Complexity: No special conditions — reliably repeatable

✓ lowers the bar for an attacker · ⚠ raises it

Proof of concept

No public PoC is currently catalogued.

Search for new PoCs

Search GitHub now — results may be empty or unverified.

Tracked sources are checked daily for recent CVEs, including PoCs published after the original disclosure. A later release appears after a tracked source lists it and a refresh succeeds.

Data snapshot:

Affected

Vendors Backstage @Backstage Linuxfoundation

Products Backstage Plugin Scaffolder Backend Module Confluence To Markdown Backstage\/Plugin Scaffolder Backend Module Confluence To Markdown

Weakness (CWE)

  • CWE-22: : Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
  • CWE-73: : External Control of File Name or Path

CVSS vector

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:L

References and research data (JSON)

Packages and version ranges

Each advisory describes its own package and affected ranges. A boundary applies to that range; it is not a universal upgrade recommendation.

  • @backstage/plugin-scaffolder-backend-module-confluence-to-markdown npm

    pkg:npm/%40backstage/plugin-scaffolder-backend-module-confluence-to-markdown

    SEMVER range
    • All earlier versions (introduced 0)
    • Fixed boundary (excluded): 0.3.25
    Additional upstream package constraints
    {
      "database": {
        "source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-75qf-886x-5xf2/GHSA-75qf-886x-5xf2.json"
      }
    }
    GitHub Advisory Database · GHSA-75qf-886x-5xf2 · Updated 2026-10-07T18:15:12.760429318Z

Known Affected Software Configurations

VendorProductVersion range
LinuxfoundationBackstage\/Plugin Scaffolder Backend Module Confluence To Markdown< 0.3.25
LinuxfoundationBackstage< 1.54.6

All CVSS metrics

  • MEDIUM 6.3 v3.1 · CNA Primary
    CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:L
  • MEDIUM 6.3 v3.1 · NVD Secondary
    CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:L
  • MEDIUM 6.5 v3.1 · NVD Primary
    CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N

References

Patches & mitigations

Advisories

Technical & other

Sources: NVD · CVE.org · EPSS