← Search CVEs

CVE-2026-106560

HIGH 7.1

Published 2026-10-07 · Last modified 2026-10-07

Backstage is an open framework for building developer portals. Prior to 0.3.25, the @backstage/plugin-scaffolder-backend-module-confluence-to-markdown package is affected by improper repository path validation in a scaffolder backend module. An authenticated user who can execute an affected template and control its repository file location may cause generated content to be written outside the task workspace, within locations writable by the Backstage backend process. This issue is fixed in version 0.3.25.

ELEVATED IMPACT

Severe if exploited (CVSS 7.1), but no known exploitation and low modeled probability. Patch on a normal cadence.

Exploitation likelihood

0.3%chance of exploitation in 30 days · 24th percentile

○ In CISA KEV ○ Catalogued PoC

Impact if exploited

7.1CVSS 3.1 · HIGH

  • ConfidentialityNone
  • IntegrityHigh
  • AvailabilityLow

What an attacker needs

  • ✓Access: Reachable over the network — no local access needed
  • ⚠Privileges: Requires a low-privilege account
  • ✓User interaction: No user interaction needed
  • ✓Complexity: No special conditions — reliably repeatable

✓ lowers the bar for an attacker · ⚠ raises it

Proof of concept

No public PoC is currently catalogued.

Search for new PoCs

Search GitHub now — results may be empty or unverified.

Tracked sources are checked daily for recent CVEs, including PoCs published after the original disclosure. A later release appears after a tracked source lists it and a refresh succeeds.

Data snapshot:

Affected

Vendors Backstage @Backstage Linuxfoundation

Products Backstage Plugin Scaffolder Backend Module Confluence To Markdown Backstage\/Plugin Scaffolder Backend Module Confluence To Markdown

Weakness (CWE)

  • CWE-22: : Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

CVSS vector

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L

References and research data (JSON)

Packages and version ranges

Each advisory describes its own package and affected ranges. A boundary applies to that range; it is not a universal upgrade recommendation.

  • @backstage/plugin-scaffolder-backend-module-confluence-to-markdown npm

    pkg:npm/%40backstage/plugin-scaffolder-backend-module-confluence-to-markdown

    SEMVER range
    • All earlier versions (introduced 0)
    • Fixed boundary (excluded): 0.3.25
    Additional upstream package constraints
    {
      "database": {
        "source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-2cmg-v53w-8xfp/GHSA-2cmg-v53w-8xfp.json"
      }
    }
    GitHub Advisory Database · GHSA-2cmg-v53w-8xfp · Updated 2026-10-07T18:15:12.669705446Z

Known Affected Software Configurations

VendorProductVersion range
LinuxfoundationBackstage\/Plugin Scaffolder Backend Module Confluence To Markdown< 0.3.25
LinuxfoundationBackstage< 1.54.6

All CVSS metrics

  • HIGH 7.1 v3.1 · CNA Primary
    CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L
  • HIGH 7.1 v3.1 · NVD Secondary
    CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:L
  • MEDIUM 6.5 v3.1 · NVD Primary
    CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

References

Patches & mitigations

Advisories

Technical & other

Sources: NVD · CVE.org · EPSS