← Search CVEs

CVE-2026-106563

MEDIUM 5.3

Published 2026-10-07 · Last modified 2026-10-10

Backstage is an open framework for building developer portals. Prior to 0.21.8, the @backstage/plugin-kubernetes-backend package is affected by improper entity validation in deprecated kubernetes services endpoint. An authenticated user with Kubernetes read permissions could access Kubernetes workload data beyond their intended scope by supplying crafted entity data to the deprecated services endpoint. The exposure is limited to read-only access to Kubernetes object metadata across configured clusters. This issue is fixed in version 0.21.8.

NO EXPLOITATION SIGNALS

No known exploitation, public exploit, or elevated probability at this time. Track for changes.

Exploitation likelihood

0.2%chance of exploitation in 30 days · 13th percentile

○ In CISA KEV ○ Catalogued PoC

Impact if exploited

5.3CVSS 3.1 · MEDIUM

  • ConfidentialityHigh
  • IntegrityNone
  • AvailabilityNone

What an attacker needs

  • ✓Access: Reachable over the network — no local access needed
  • ⚠Privileges: Requires a low-privilege account
  • ✓User interaction: No user interaction needed
  • ⚠Complexity: Needs a race window or specific setup

✓ lowers the bar for an attacker · ⚠ raises it

Proof of concept

No public PoC is currently catalogued.

Search for new PoCs

Search GitHub now — results may be empty or unverified.

Tracked sources are checked daily for recent CVEs, including PoCs published after the original disclosure. A later release appears after a tracked source lists it and a refresh succeeds.

Data snapshot:

Affected

Vendors Backstage @Backstage Linuxfoundation

Products Backstage Plugin Kubernetes Backend Backstage\/Plugin Kubernetes Backend

Weakness (CWE)

  • CWE-20: : Improper Input Validation
  • CWE-862: : Missing Authorization

CVSS vector

CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N

References and research data (JSON)

Packages and version ranges

Each advisory describes its own package and affected ranges. A boundary applies to that range; it is not a universal upgrade recommendation.

  • @backstage/plugin-kubernetes-backend npm

    pkg:npm/%40backstage/plugin-kubernetes-backend

    SEMVER range
    • All earlier versions (introduced 0)
    • Fixed boundary (excluded): 0.21.8
    Additional upstream package constraints
    {
      "database": {
        "source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-r9ph-3637-55px/GHSA-r9ph-3637-55px.json"
      }
    }
    GitHub Advisory Database · GHSA-r9ph-3637-55px · Updated 2026-10-07T18:15:11.761928207Z

Known Affected Software Configurations

VendorProductVersion range
LinuxfoundationBackstage\/Plugin Kubernetes Backend< 0.21.8
LinuxfoundationBackstage< 1.54.1

All CVSS metrics

  • MEDIUM 5.3 v3.1 · CNA Primary
    CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
  • MEDIUM 5.3 v3.1 · NVD Secondary
    CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N
  • MEDIUM 6.5 v3.1 · NVD Primary
    CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

References

Patches & mitigations

Advisories

Technical & other

Sources: NVD · CVE.org · EPSS