← Search CVEs

CVE-2026-107807

HIGH 8.8

Published 2026-10-09 · Last modified 2026-10-09

Nginx UI is a web user interface for the Nginx web server. From 2.0.0 until 2.5.0, Nginx UI accepts the Node.Secret master credential through the node_secret query parameter in HTTP and WebSocket authentication paths instead of requiring the X-Node-Secret header. The credential can consequently appear in access logs, proxy logs, browser history, Referer headers, configuration URLs, and deployment environment data. A party that obtains the secret can bypass normal password, JWT, session, and second-factor checks and obtain persistent administrative API access, including access to configuration and secret material. This issue is fixed in version 2.5.0.

ELEVATED IMPACT

Severe if exploited (CVSS 8.8), but no known exploitation and low modeled probability. Patch on a normal cadence.

Exploitation likelihood

0.3%chance of exploitation in 30 days · 22nd percentile

○ In CISA KEV ○ Catalogued PoC

Impact if exploited

8.8CVSS 3.1 · HIGH

  • ConfidentialityHigh
  • IntegrityHigh
  • AvailabilityHigh

What an attacker needs

  • ✓Access: Reachable over the network — no local access needed
  • ⚠Privileges: Requires a low-privilege account
  • ✓User interaction: No user interaction needed
  • ✓Complexity: No special conditions — reliably repeatable

✓ lowers the bar for an attacker · ⚠ raises it

Proof of concept

No public PoC is currently catalogued.

Search for new PoCs

Search GitHub now — results may be empty or unverified.

Tracked sources are checked daily for recent CVEs, including PoCs published after the original disclosure. A later release appears after a tracked source lists it and a refresh succeeds.

Data snapshot:

Affected

Vendors 0xjacky Nginxui

Products Nginx Ui Nginx Ui

Weakness (CWE)

  • CWE-312: : Cleartext Storage of Sensitive Information
  • CWE-598: : Use of GET Request Method With Sensitive Query Strings

CVSS vector

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

References and research data (JSON)

Packages and version ranges

Each advisory describes its own package and affected ranges. A boundary applies to that range; it is not a universal upgrade recommendation.

  • github.com/0xJacky/Nginx-UI Go

    pkg:golang/github.com/0xJacky/Nginx-UI

    SEMVER range
    • Introduced version (included): 1.9.10-0.20250517140552-daee3ac7ade1
    • Fixed boundary (excluded): 1.9.10-0.20260728074433-a3999bd78a3b
    Additional upstream package constraints
    {
      "database": {
        "source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-pvgv-gcp7-v38g/GHSA-pvgv-gcp7-v38g.json"
      }
    }
    GitHub Advisory Database · GHSA-pvgv-gcp7-v38g · Updated 2026-10-19T21:41:21.908207364Z
  • github.com/0xJacky/Nginx-UI Go

    pkg:golang/github.com/0xJacky/Nginx-UI

    SEMVER range
    • Introduced version (included): 1.9.10-0.20250517140552-daee3ac7ade1
    • Fixed boundary (excluded): 1.9.10-0.20260728074433-a3999bd78a3b
    Additional upstream package constraints
    {
      "ecosystem": {},
      "database": {
        "source": "https://vuln.go.dev/ID/GO-2026-6708.json"
      }
    }
    Go Vulnerability Database · GO-2026-6708 · Updated 2026-10-19T21:31:49.018903603Z

Known Affected Software Configurations

VendorProductVersion range
NginxuiNginx Ui≥ 2.0.0 and < 2.5.0

All CVSS metrics

  • HIGH 8.8 v3.1 · CNA Primary
    CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
  • HIGH 8.8 v3.1 · NVD Secondary
    CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

References

Exploit-tagged references (not proof of a PoC)

Patches & mitigations

Advisories

Technical & other

Sources: NVD · CVE.org · EPSS