← Search CVEs

CVE-2026-107808

HIGH 8.1

Published 2026-10-09 · Last modified 2026-10-09

Nginx UI is a web user interface for the Nginx web server. From 2.0.0 until 2.5.0, POST /api/login checks EnabledOTP but does not require a WebAuthn assertion when EnabledPasskey is true and no TOTP secret is configured. A passkey-only account is therefore issued a session after password verification, despite Enabled2FA reporting that the account has a second factor. An attacker who obtains the password can take over the account and reach administrative functionality without the registered passkey. This issue is fixed in version 2.5.0.

ELEVATED IMPACT

Severe if exploited (CVSS 8.1), but no known exploitation and low modeled probability. Patch on a normal cadence.

Exploitation likelihood

0.4%chance of exploitation in 30 days · 35th percentile

○ In CISA KEV ○ Catalogued PoC

Impact if exploited

8.1CVSS 3.1 · HIGH

  • ConfidentialityHigh
  • IntegrityHigh
  • AvailabilityHigh

What an attacker needs

  • ✓Access: Reachable over the network — no local access needed
  • ✓Privileges: No account or privileges required
  • ✓User interaction: No user interaction needed
  • ⚠Complexity: Needs a race window or specific setup

✓ lowers the bar for an attacker · ⚠ raises it

Proof of concept

No public PoC is currently catalogued.

Search for new PoCs

Search GitHub now — results may be empty or unverified.

Tracked sources are checked daily for recent CVEs, including PoCs published after the original disclosure. A later release appears after a tracked source lists it and a refresh succeeds.

Data snapshot:

Affected

Vendors 0xjacky Nginxui

Products Nginx Ui Nginx Ui

Weakness (CWE)

  • CWE-287: : Improper Authentication
  • CWE-305: : Authentication Bypass by Primary Weakness
  • CWE-308: : Use of Single-factor Authentication

CVSS vector

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

References and research data (JSON)

Packages and version ranges

Each advisory describes its own package and affected ranges. A boundary applies to that range; it is not a universal upgrade recommendation.

  • github.com/0xJacky/Nginx-UI Go

    pkg:golang/github.com/0xJacky/Nginx-UI

    SEMVER range
    • Introduced version (included): 1.9.10-0.20250517140552-daee3ac7ade1
    • Fixed boundary (excluded): 1.9.10-0.20260728074558-95cd21b70814
    Additional upstream package constraints
    {
      "database": {
        "source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-45gv-9wjv-xh7p/GHSA-45gv-9wjv-xh7p.json"
      }
    }
    GitHub Advisory Database · GHSA-45gv-9wjv-xh7p · Updated 2026-10-19T21:41:12.332793483Z
  • github.com/0xJacky/Nginx-UI Go

    pkg:golang/github.com/0xJacky/Nginx-UI

    SEMVER range
    • Introduced version (included): 1.9.10-0.20250517140552-daee3ac7ade1
    • Fixed boundary (excluded): 1.9.10-0.20260728074558-95cd21b70814
    Additional upstream package constraints
    {
      "ecosystem": {},
      "database": {
        "source": "https://vuln.go.dev/ID/GO-2026-6704.json"
      }
    }
    Go Vulnerability Database · GO-2026-6704 · Updated 2026-10-19T21:31:49.017741285Z

Known Affected Software Configurations

VendorProductVersion range
NginxuiNginx Ui≥ 2.0.0 and < 2.5.0

All CVSS metrics

  • HIGH 8.1 v3.1 · CNA Primary
    CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
  • HIGH 8.1 v3.1 · NVD Secondary
    CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

References

Exploit-tagged references (not proof of a PoC)

Patches & mitigations

Advisories

Technical & other

Sources: NVD · CVE.org · EPSS