← Search CVEs

CVE-2026-107809

HIGH 8.8

Published 2026-10-09 · Last modified 2026-10-09

Nginx UI is a web user interface for the Nginx web server. From 2.0.0 until 2.5.0, AuthRequired accepts a browser-managed token cookie as an API credential after the front end stores the JWT in that cookie. Because management endpoints do not universally require a CSRF token or perform Origin or Referer validation, a remote attacker can induce a logged-in administrator's browser to submit authenticated cross-site state-changing requests, including POST /api/configs. The attack requires an administrator account without OTP/Passkey or a target endpoint that does not require secure-session proof. The attacker cannot read the cross-origin response but can modify Nginx configuration, trigger reloads, or invoke other management operations reachable with the victim's session. This issue is fixed in version 2.5.0.

ELEVATED IMPACT

Severe if exploited (CVSS 8.8), but no known exploitation and low modeled probability. Patch on a normal cadence.

Exploitation likelihood

0.2%chance of exploitation in 30 days · 13th percentile

○ In CISA KEV ○ Catalogued PoC

Impact if exploited

8.8CVSS 3.1 · HIGH

  • ConfidentialityHigh
  • IntegrityHigh
  • AvailabilityHigh

What an attacker needs

  • ✓Access: Reachable over the network — no local access needed
  • ✓Privileges: No account or privileges required
  • ⚠User interaction: A user must take an action (click / open a file)
  • ✓Complexity: No special conditions — reliably repeatable

✓ lowers the bar for an attacker · ⚠ raises it

Proof of concept

No public PoC is currently catalogued.

Search for new PoCs

Search GitHub now — results may be empty or unverified.

Tracked sources are checked daily for recent CVEs, including PoCs published after the original disclosure. A later release appears after a tracked source lists it and a refresh succeeds.

Data snapshot:

Affected

Vendors 0xjacky Nginxui

Products Nginx Ui Nginx Ui

Weakness (CWE)

  • CWE-352: : Cross-Site Request Forgery (CSRF)

CVSS vector

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

References and research data (JSON)

Packages and version ranges

Each advisory describes its own package and affected ranges. A boundary applies to that range; it is not a universal upgrade recommendation.

  • github.com/0xJacky/Nginx-UI Go

    pkg:golang/github.com/0xJacky/Nginx-UI

    SEMVER range
    • Introduced version (included): 1.9.10-0.20250517140552-daee3ac7ade1
    • Fixed boundary (excluded): 1.9.10-0.20260728074433-a3999bd78a3b
    Additional upstream package constraints
    {
      "database": {
        "source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-33rr-wq23-g6gg/GHSA-33rr-wq23-g6gg.json"
      }
    }
    GitHub Advisory Database · GHSA-33rr-wq23-g6gg · Updated 2026-10-19T21:41:07.284327902Z
  • github.com/0xJacky/Nginx-UI Go

    pkg:golang/github.com/0xJacky/Nginx-UI

    SEMVER range
    • Introduced version (included): 1.9.10-0.20250517140552-daee3ac7ade1
    • Fixed boundary (excluded): 1.9.10-0.20260728074433-a3999bd78a3b
    Additional upstream package constraints
    {
      "ecosystem": {},
      "database": {
        "source": "https://vuln.go.dev/ID/GO-2026-6703.json"
      }
    }
    Go Vulnerability Database · GO-2026-6703 · Updated 2026-10-19T21:31:52.274284585Z

Known Affected Software Configurations

VendorProductVersion range
NginxuiNginx Ui≥ 2.0.0 and < 2.5.0

All CVSS metrics

  • HIGH 8.8 v3.1 · CNA Primary
    CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
  • HIGH 8.8 v3.1 · NVD Secondary
    CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

References

Exploit-tagged references (not proof of a PoC)

Patches & mitigations

Advisories

Technical & other

Sources: NVD · CVE.org · EPSS