← Search CVEs

CVE-2026-107813

HIGH 8.8

Published 2026-10-09 · Last modified 2026-10-09

Nginx UI is a web user interface for the Nginx web server. From 2.0.0 until 2.5.0, the api/cluster router exposes node and namespace mutation operations and cluster-wide Nginx reload or restart operations with AuthRequired but without RequireSecureSession. An authenticated OTP-enabled user possessing a stolen or persisted JWT can therefore perform node CRUD, read or replace node credentials, change namespaces, and invoke nodes/reload_nginx or nodes/restart_nginx without a fresh second-factor step-up. This issue is an incomplete fix for CVE-2026-84315 and is fixed in version 2.5.0.

ELEVATED IMPACT

Severe if exploited (CVSS 8.8), but no known exploitation and low modeled probability. Patch on a normal cadence.

Exploitation likelihood

0.3%chance of exploitation in 30 days · 23rd percentile

○ In CISA KEV ○ Catalogued PoC

Impact if exploited

8.8CVSS 3.1 · HIGH

  • ConfidentialityHigh
  • IntegrityHigh
  • AvailabilityHigh

What an attacker needs

  • ✓Access: Reachable over the network — no local access needed
  • ⚠Privileges: Requires a low-privilege account
  • ✓User interaction: No user interaction needed
  • ✓Complexity: No special conditions — reliably repeatable

✓ lowers the bar for an attacker · ⚠ raises it

Proof of concept

No public PoC is currently catalogued.

Search for new PoCs

Search GitHub now — results may be empty or unverified.

Tracked sources are checked daily for recent CVEs, including PoCs published after the original disclosure. A later release appears after a tracked source lists it and a refresh succeeds.

Data snapshot:

Affected

Vendors 0xjacky Nginxui

Products Nginx Ui Nginx Ui

Weakness (CWE)

  • CWE-862: : Missing Authorization

CVSS vector

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

References and research data (JSON)

Packages and version ranges

Each advisory describes its own package and affected ranges. A boundary applies to that range; it is not a universal upgrade recommendation.

  • github.com/0xJacky/Nginx-UI Go

    pkg:golang/github.com/0xJacky/Nginx-UI

    SEMVER range
    • Introduced version (included): 1.9.10-0.20250517140552-daee3ac7ade1
    • Fixed boundary (excluded): 1.9.10-0.20260728074433-a3999bd78a3b
    Additional upstream package constraints
    {
      "database": {
        "source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-h246-wpgf-vmq5/GHSA-h246-wpgf-vmq5.json"
      }
    }
    GitHub Advisory Database · GHSA-h246-wpgf-vmq5 · Updated 2026-10-19T21:40:57.819406134Z
  • github.com/0xJacky/Nginx-UI Go

    pkg:golang/github.com/0xJacky/Nginx-UI

    SEMVER range
    • Introduced version (included): 1.9.10-0.20250517140552-daee3ac7ade1
    • Fixed boundary (excluded): 1.9.10-0.20260728074433-a3999bd78a3b
    Additional upstream package constraints
    {
      "ecosystem": {},
      "database": {
        "source": "https://vuln.go.dev/ID/GO-2026-6706.json"
      }
    }
    Go Vulnerability Database · GO-2026-6706 · Updated 2026-10-19T21:31:39.266611356Z

Known Affected Software Configurations

VendorProductVersion range
NginxuiNginx Ui≥ 2.0.0 and < 2.5.0

All CVSS metrics

  • HIGH 8.8 v3.1 · CNA Primary
    CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
  • HIGH 8.8 v3.1 · NVD Secondary
    CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

References

Patches & mitigations

Advisories

Technical & other

Sources: NVD · CVE.org · EPSS