← Search CVEs

CVE-2026-112951

MEDIUM 5.4

Published 2026-10-20 · Last modified 2026-10-20

ApostropheCMS is an open-source Node.js content management system. Prior to 4.34.0, the color field accepts trailing content after a valid rgb() or hsl() prefix because its TinyColor validation does not require the entire value to match a color. An authenticated user with edit rights can store arbitrary HTML after a valid color prefix. When the stored value is rendered, the payload executes, resulting in stored XSS. This issue is fixed in version 4.34.0.

NO EXPLOITATION SIGNALS

No known exploitation, public exploit, or elevated probability at this time. Track for changes.

Exploitation likelihood

0.3%chance of exploitation in 30 days · 23rd percentile

○ In CISA KEV ○ Catalogued PoC

Impact if exploited

5.4CVSS 3.1 · MEDIUM

  • ConfidentialityLow
  • IntegrityLow
  • AvailabilityNone

What an attacker needs

  • ✓Access: Reachable over the network — no local access needed
  • ⚠Privileges: Requires a low-privilege account
  • ⚠User interaction: A user must take an action (click / open a file)
  • ✓Complexity: No special conditions — reliably repeatable

✓ lowers the bar for an attacker · ⚠ raises it

Proof of concept

No public PoC is currently catalogued.

Search for new PoCs

Search GitHub now — results may be empty or unverified.

Tracked sources are checked daily for recent CVEs, including PoCs published after the original disclosure. A later release appears after a tracked source lists it and a refresh succeeds.

Data snapshot:

Affected

Vendors Apostrophecms

Products Apostrophe

Weakness (CWE)

  • CWE-79: : Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

CVSS vector

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

References and research data (JSON)

Packages and version ranges

Each advisory describes its own package and affected ranges. A boundary applies to that range; it is not a universal upgrade recommendation.

  • apostrophe npm

    pkg:npm/apostrophe

    SEMVER range
    • All earlier versions (introduced 0)
    • Fixed boundary (excluded): 4.34.0
    Additional upstream package constraints
    {
      "database": {
        "source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-vmgj-9cwm-cf3h/GHSA-vmgj-9cwm-cf3h.json"
      }
    }
    GitHub Advisory Database · GHSA-vmgj-9cwm-cf3h · Updated 2026-10-21T17:15:08.647725268Z

All CVSS metrics

  • MEDIUM 5.4 v3.1 · CNA Primary
    CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
  • MEDIUM 5.4 v3.1 · NVD Secondary
    CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

References

Exploit-tagged references (not proof of a PoC)

Advisories

Technical & other

Sources: NVD · CVE.org · EPSS