← Search CVEs

CVE-2026-57142

HIGH 7.8

Published 2026-10-23 · Last modified 2026-10-23

PraisonAI is a multi-agent teams system. From version 4.5.87 to before version 4.6.61, PraisonAI recipe execution has a dangerous-tool policy that is supposed to block default-denied tools unless the caller explicitly passes allow_dangerous_tools=True. That policy only checks tools declared in TEMPLATE.yaml requires.tools. For steps-based recipes, the actual execution path loads workflow.yaml with YAMLWorkflowParser. That parser resolves agent-level tools: declarations and preserves top-level approve:. Workflow.start() then installs those YAML-approved tools into the approval context. As a result, an untrusted recipe can omit execute_command from TEMPLATE.yaml requires.tools, declare it in workflow.yaml agents.*.tools, and add top-level approve: [execute_command]. The caller did not set allow_dangerous_tools=True, but the recipe policy allows the recipe and the workflow approval path self-approves the critical shell tool. This issue has been patched in version 4.6.61.

ELEVATED IMPACT

Severe if exploited (CVSS 7.8), but no known exploitation and low modeled probability. Patch on a normal cadence.

Exploitation likelihood

0.1%chance of exploitation in 30 days · 4th percentile

○ In CISA KEV ○ Catalogued PoC

Impact if exploited

7.8CVSS 3.1 · HIGH

  • ConfidentialityHigh
  • IntegrityHigh
  • AvailabilityHigh

What an attacker needs

  • ⚠Access: Requires local access to the host
  • ✓Privileges: No account or privileges required
  • ⚠User interaction: A user must take an action (click / open a file)
  • ✓Complexity: No special conditions — reliably repeatable

✓ lowers the bar for an attacker · ⚠ raises it

Proof of concept

No public PoC is currently catalogued.

Search for new PoCs

Search GitHub now — results may be empty or unverified.

Tracked sources are checked daily for recent CVEs, including PoCs published after the original disclosure. A later release appears after a tracked source lists it and a refresh succeeds.

Data snapshot:

Affected

Vendors Mervinpraison

Products Praisonai

Weakness (CWE)

  • CWE-78: : Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')
  • CWE-94: : Improper Control of Generation of Code ('Code Injection')
  • CWE-863: : Incorrect Authorization

CVSS vector

CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

References and research data (JSON)

Packages and version ranges

Each advisory describes its own package and affected ranges. A boundary applies to that range; it is not a universal upgrade recommendation.

  • praisonai PyPI

    pkg:pypi/praisonai

    ECOSYSTEM range
    • Introduced version (included): 4.5.87
    • Fixed boundary (excluded): 4.6.61
    103 explicitly listed affected versions

    4.5.100, 4.5.101, 4.5.102, 4.5.103, 4.5.104, 4.5.105, 4.5.106, 4.5.107, 4.5.108, 4.5.109, 4.5.110, 4.5.111, 4.5.112, 4.5.113, 4.5.114, 4.5.115, 4.5.117, 4.5.118, 4.5.119, 4.5.120, 4.5.121, 4.5.122, 4.5.123, 4.5.124, 4.5.125, 4.5.126, 4.5.127, 4.5.128, 4.5.129, 4.5.130, 4.5.131, 4.5.132, 4.5.133, 4.5.134, 4.5.135, 4.5.136, 4.5.137, 4.5.139, 4.5.140, 4.5.143, 4.5.144, 4.5.145, 4.5.149, 4.5.87, 4.5.88, 4.5.89, 4.5.90, 4.5.93, 4.5.94, 4.5.95, 4.5.96, 4.5.97, 4.5.98, 4.6.10, 4.6.11, 4.6.12, 4.6.13, 4.6.14, 4.6.15, 4.6.16, 4.6.18, 4.6.19, 4.6.20, 4.6.21, 4.6.22, 4.6.23, 4.6.24, 4.6.25, 4.6.26, 4.6.27, 4.6.28, 4.6.29, 4.6.30, 4.6.31, 4.6.32, 4.6.33, 4.6.34, 4.6.35, 4.6.36, 4.6.37, 4.6.38, 4.6.39, 4.6.40, 4.6.41, 4.6.42, 4.6.43, 4.6.44, 4.6.45, 4.6.46, 4.6.47, 4.6.48, 4.6.50, 4.6.51, 4.6.52, 4.6.53, 4.6.54, 4.6.55, 4.6.56, 4.6.57, 4.6.58, 4.6.59, 4.6.60, 4.6.9

    Additional upstream package constraints
    {
      "database": {
        "source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/06/GHSA-7qw2-w5rc-37x2/GHSA-7qw2-w5rc-37x2.json"
      }
    }
    GitHub Advisory Database · GHSA-7qw2-w5rc-37x2 · Updated 2026-07-23T15:11:22.645330452Z
  • praisonai PyPI

    pkg:pypi/praisonai

    ECOSYSTEM range
    • Introduced version (included): 4.5.87
    • Fixed boundary (excluded): 4.6.61
    103 explicitly listed affected versions

    4.5.100, 4.5.101, 4.5.102, 4.5.103, 4.5.104, 4.5.105, 4.5.106, 4.5.107, 4.5.108, 4.5.109, 4.5.110, 4.5.111, 4.5.112, 4.5.113, 4.5.114, 4.5.115, 4.5.117, 4.5.118, 4.5.119, 4.5.120, 4.5.121, 4.5.122, 4.5.123, 4.5.124, 4.5.125, 4.5.126, 4.5.127, 4.5.128, 4.5.129, 4.5.130, 4.5.131, 4.5.132, 4.5.133, 4.5.134, 4.5.135, 4.5.136, 4.5.137, 4.5.139, 4.5.140, 4.5.143, 4.5.144, 4.5.145, 4.5.149, 4.5.87, 4.5.88, 4.5.89, 4.5.90, 4.5.93, 4.5.94, 4.5.95, 4.5.96, 4.5.97, 4.5.98, 4.6.10, 4.6.11, 4.6.12, 4.6.13, 4.6.14, 4.6.15, 4.6.16, 4.6.18, 4.6.19, 4.6.20, 4.6.21, 4.6.22, 4.6.23, 4.6.24, 4.6.25, 4.6.26, 4.6.27, 4.6.28, 4.6.29, 4.6.30, 4.6.31, 4.6.32, 4.6.33, 4.6.34, 4.6.35, 4.6.36, 4.6.37, 4.6.38, 4.6.39, 4.6.40, 4.6.41, 4.6.42, 4.6.43, 4.6.44, 4.6.45, 4.6.46, 4.6.47, 4.6.48, 4.6.50, 4.6.51, 4.6.52, 4.6.53, 4.6.54, 4.6.55, 4.6.56, 4.6.57, 4.6.58, 4.6.59, 4.6.60, 4.6.9

    Additional upstream package constraints
    {
      "database": {
        "source": "https://github.com/pypa/advisory-database/blob/main/vulns/praisonai/PYSEC-2026-3505.yaml"
      }
    }
    PyPA · PYSEC-2026-3505 · Updated 2026-07-23T15:00:20.673849210Z

All CVSS metrics

  • HIGH 7.8 v3.1 · CNA Primary
    CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
  • HIGH 7.8 v3.1 · NVD Secondary
    CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

References

Advisories

Technical & other

Sources: NVD · CVE.org · EPSS