← Search CVEs

CVE-2026-82416

HIGH 7.7

Published 2026-10-13 · Last modified 2026-10-13

FrankenPHP is a modern application server for PHP. Prior to 1.12.5, FrankenPHP worker mode can retain PHP session state between requests when the session extension is loaded as a shared module and is unavailable through HAVE_PHP_SESSION at compile time. In this build configuration, frankenphp_reset_session_state() is compiled out, PS(id) can survive a request boundary, and a subsequent session_start() can ignore the new request's cookie because an identifier is already present. Under concurrent requests, session_id() can therefore return another client's identifier or a stale identifier from a previous request on the same worker thread, causing cross-user session exposure, possible session hijacking, and intermittent logout behavior. Builds with the session extension statically linked, including the official static binaries and Docker images, are not affected. This issue is fixed in version 1.12.5.

ELEVATED IMPACT

Severe if exploited (CVSS 7.7), but no known exploitation and low modeled probability. Patch on a normal cadence.

Exploitation likelihood

0.2%chance of exploitation in 30 days · 13th percentile

○ In CISA KEV ○ Catalogued PoC

Impact if exploited

7.7CVSS 3.1 · HIGH

  • ConfidentialityHigh
  • IntegrityHigh
  • AvailabilityLow

What an attacker needs

  • ✓Access: Reachable over the network — no local access needed
  • ✓Privileges: No account or privileges required
  • ✓User interaction: No user interaction needed
  • ⚠Complexity: Needs a race window or specific setup

✓ lowers the bar for an attacker · ⚠ raises it

Proof of concept

No public PoC is currently catalogued.

Search for new PoCs

Search GitHub now — results may be empty or unverified.

Tracked sources are checked daily for recent CVEs, including PoCs published after the original disclosure. A later release appears after a tracked source lists it and a refresh succeeds.

Data snapshot:

Affected

Vendors Php

Products Frankenphp

Weakness (CWE)

  • CWE-362: : Concurrent Execution using Shared Resource with Improper Synchronization ('Race Condition')
  • CWE-488: : Exposure of Data Element to Wrong Session

CVSS vector

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L

References and research data (JSON)

Packages and version ranges

Each advisory describes its own package and affected ranges. A boundary applies to that range; it is not a universal upgrade recommendation.

  • github.com/dunglas/frankenphp Go

    pkg:golang/github.com/dunglas/frankenphp

    SEMVER range
    • All earlier versions (introduced 0)
    • Fixed boundary (excluded): 1.12.5
    Additional upstream package constraints
    {
      "database": {
        "last_known_affected_version_range": "<= 1.12.4",
        "source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-v3ph-cgqh-r8p5/GHSA-v3ph-cgqh-r8p5.json"
      }
    }
    GitHub Advisory Database · GHSA-v3ph-cgqh-r8p5 · Updated 2026-10-19T21:41:08.985899527Z
  • github.com/dunglas/frankenphp Go

    pkg:golang/github.com/dunglas/frankenphp

    SEMVER range
    • All earlier versions (introduced 0)
    • Fixed boundary (excluded): 1.12.5
    Additional upstream package constraints
    {
      "ecosystem": {},
      "database": {
        "source": "https://vuln.go.dev/ID/GO-2026-6797.json"
      }
    }
    Go Vulnerability Database · GO-2026-6797 · Updated 2026-10-19T21:31:38.315371943Z

All CVSS metrics

  • HIGH 7.7 v3.1 · CNA Primary
    CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L
  • HIGH 7.7 v3.1 · NVD Secondary
    CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:L

References

Advisories

Technical & other

Sources: NVD · CVE.org · EPSS