← Search CVEs

CVE-2026-84360

HIGH 8.1

Published 2026-10-12 · Last modified 2026-10-13

Nginx UI is a web user interface for the Nginx web server. Prior to 2.4.1, the HTTP configuration mutation routes require RequireSecureSession, but /mcp and /mcp_message require only ordinary authentication before exposing nginx_config_add and nginx_config_modify. An OTP-enabled user with a normal JWT but no valid X-Secure-Session-ID can therefore create or modify Nginx configuration and trigger reload behavior through MCP, bypassing the intended step-up control. This issue is fixed in version 2.4.1.

ELEVATED IMPACT

Severe if exploited (CVSS 8.1), but no known exploitation and low modeled probability. Patch on a normal cadence.

Exploitation likelihood

0.4%chance of exploitation in 30 days · 36th percentile

○ In CISA KEV ○ Catalogued PoC

Impact if exploited

8.1CVSS 3.1 · HIGH

  • ConfidentialityNone
  • IntegrityHigh
  • AvailabilityHigh

What an attacker needs

  • ✓Access: Reachable over the network — no local access needed
  • ⚠Privileges: Requires a low-privilege account
  • ✓User interaction: No user interaction needed
  • ✓Complexity: No special conditions — reliably repeatable

✓ lowers the bar for an attacker · ⚠ raises it

Proof of concept

No public PoC is currently catalogued.

Search for new PoCs

Search GitHub now — results may be empty or unverified.

Tracked sources are checked daily for recent CVEs, including PoCs published after the original disclosure. A later release appears after a tracked source lists it and a refresh succeeds.

Data snapshot:

Affected

Vendors 0xjacky

Products Nginx Ui

Weakness (CWE)

  • CWE-288: : Authentication Bypass Using an Alternate Path or Channel

CVSS vector

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H

References and research data (JSON)

Packages and version ranges

Each advisory describes its own package and affected ranges. A boundary applies to that range; it is not a universal upgrade recommendation.

  • github.com/0xJacky/Nginx-UI Go

    pkg:golang/github.com/0xJacky/Nginx-UI

    SEMVER range
    • All earlier versions (introduced 0)
    • Fixed boundary (excluded): 1.9.10-0.20260703131214-23d1934099b0
    Additional upstream package constraints
    {
      "database": {
        "source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-vc32-4gwf-77xp/GHSA-vc32-4gwf-77xp.json"
      }
    }
    GitHub Advisory Database · GHSA-vc32-4gwf-77xp · Updated 2026-10-19T21:41:02.724775704Z
  • github.com/0xJacky/Nginx-UI Go

    pkg:golang/github.com/0xJacky/Nginx-UI

    SEMVER range
    • All earlier versions (introduced 0)
    • Fixed boundary (excluded): 1.9.10-0.20260703131214-23d1934099b0
    Additional upstream package constraints
    {
      "ecosystem": {},
      "database": {
        "source": "https://vuln.go.dev/ID/GO-2026-6799.json"
      }
    }
    Go Vulnerability Database · GO-2026-6799 · Updated 2026-10-19T21:31:53.417011797Z

All CVSS metrics

  • HIGH 8.1 v3.1 · CNA Primary
    CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
  • HIGH 8.1 v3.1 · NVD Secondary
    CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H

References

Exploit-tagged references (not proof of a PoC)

Advisories

Technical & other

Sources: NVD · CVE.org · EPSS